Home  |  Linux  | Mysql  | PHP  | XML
Date:Thu Jun 13 11:20:15 2019
Subject:Bug #78106 [Csd]: Path resolution fails if opcache disabled during request
Edit report at https://bugs.php.net/bug.php?id=78106&edit=1

ID: 78106
User updated by: mbiebl at messageconcept dot com
Reported by: mbiebl at messageconcept dot com
Summary: Path resolution fails if opcache disabled during
request
Status: Closed
Type: Bug
Package: opcache
Operating System: Windows Server 2016 / IIS 10
PHP Version: 7.2.19
Assigned To: dmitry
Block user comment: N
Private report: N

New Comment:

Since I can only reproduce that issue with 7.2.19, I would need a daily build from the 7.2 branch with that fix included.


Previous Comments:
------------------------------------------------------------------------
[2019-06-13 11:02:21] mbiebl at messageconcept dot com

Just curious: In my case, there is no explicit `ini_set('opcache.enable', 0);` anywhere in the code so I wonder if this really fixes my original issue. Are there other mechanisms which implicitly disable opcache during runtime?
Anyway, I'm happy to test it once a (daily) build is available with this commit.

------------------------------------------------------------------------
[2019-06-13 10:57:54] [email protected]

The issue should be fixed by https://github.com/php/php-src/commit/f1a81380554070d7f4b0c6dcd1202364ebf3d252. It would be great if you can confirm that this also fixes your original issue.

------------------------------------------------------------------------
[2019-06-13 10:54:36] [email protected]

Automatic comment on behalf of [email protected]
Revision: http://git.php.net/?p=php-src.git;a=commit;h=f1a81380554070d7f4b0c6dcd1202364ebf3d252
Log: Fixed bug #78106

------------------------------------------------------------------------
[2019-06-13 10:49:40] [email protected]

Testcase added in https://github.com/php/php-src/commit/f8a68fd9350ac97d33d1773453c4e9d47a97b33f, with a bit of run-tests plumbing.

------------------------------------------------------------------------
[2019-06-13 08:43:00] [email protected]

@martijn at squeezely dot tech: Thanks a lot! I can confirm that this reproduces the issue for me.

------------------------------------------------------------------------


The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at

https://bugs.php.net/bug.php?id=78106


--
Edit this bug report at https://bugs.php.net/bug.php?id=78106&edit=1
Navigate in group php.bugs at sever news.php.net
Previous Next





  
© No Copyright
You are free to use Anything, but please consult your advocate before doing so as this website
also list content from other sources which may be copyrighted.