Re: [PATCH v2] sched/topology: change kzalloc to kcalloc
Markus Elfring <[email protected]> Sun, 9 Feb 2025 12:00:11 +0100
| Newsgroups | com.openwall.lists.kernel-hardening,org.kernel.vger.kernel-janitors,org.kernel.vger.linux-hardening,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
> We are replacing any instances of kzalloc(size * count, ...) with > kcalloc(count, size, ...) due to risk of overflow [1]. * See also: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/= Documentation/process/submitting-patches.rst?h=3Dv6.13#n94 * How do you think about to use a summary phrase like =E2=80=9CReplace two= kzalloc() calls by kcalloc() in sched_init_numa()=E2=80=9D? * Would you be looking for any coccicheck extensions accordingly? Regards, Markus