Re: [PATCH v2] wireguard: queueing: simplify wg_cpumask_next_online()
"Jason A. Donenfeld" <[email protected]>
| Newsgroups | com.zx2c4.lists.wireguard,org.kernel.vger.linux-kernel,org.kernel.vger.netdev |
|---|---|
| Message-ID | <[email protected]> |
On Thu, Jun 19, 2025 at 10:54:59AM -0400, Yury Norov wrote: > From: Yury Norov [NVIDIA] <[email protected]> > > wg_cpumask_choose_online() opencodes cpumask_nth(). Use it and make the > function significantly simpler. While there, fix opencoded cpu_online() > too. > > Signed-off-by: Yury Norov [NVIDIA] <[email protected]> > --- > v1: https://lore.kernel.org/all/[email protected]/ > v2: > - fix 'cpu' undeclared; > - change subject (Jason); > - keep the original function structure (Jason); > > drivers/net/wireguard/queueing.h | 13 ++++--------- > 1 file changed, 4 insertions(+), 9 deletions(-) > > diff --git a/drivers/net/wireguard/queueing.h b/drivers/net/wireguard/queueing.h > index 7eb76724b3ed..56314f98b6ba 100644 > --- a/drivers/net/wireguard/queueing.h > +++ b/drivers/net/wireguard/queueing.h > @@ -104,16 +104,11 @@ static inline void wg_reset_packet(struct sk_buff *skb, bool encapsulating) > > static inline int wg_cpumask_choose_online(int *stored_cpu, unsigned int id) > { > - unsigned int cpu = *stored_cpu, cpu_index, i; > + unsigned int cpu = *stored_cpu; > + > + if (unlikely(cpu >= nr_cpu_ids || !cpu_online(cpu))) > + cpu = *stored_cpu = cpumask_nth(id % num_online_cpus(), cpu_online_mask); I was about to apply this but then it occurred to me: what happens if cpu_online_mask changes (shrinks) after num_online_cpus() is evaluated? cpumask_nth() will then return nr_cpu_ids? Jason