Re: [PATCH net-next v3 04/11] netlink: specs: add specification for wireguard

"Jason A. Donenfeld" <[email protected]> Wed, 19 Nov 2025 20:22:57 +0100
Newsgroups com.zx2c4.lists.wireguard,org.kernel.vger.linux-kernel,org.kernel.vger.netdev
Message-ID <CAHmME9rzr8EGkTy3TduTXK45-w1CwEYnRLX=SjkAqo1CTTgVHA@mail.gmail.com>
On Wed, Nov 19, 2025 at 8:20 PM Asbjørn Sloth Tønnesen <[email protected]> wrote:
> B) Add a "operations"->"function-prefix" in YAML, only one funtion gets renamed.
>
>     wg_get_device_start(), wg_get_device_dump() and wg_get_device_done() keep
>     their names, while wg_set_device() gets renamed to wg_set_device_doit().
>
>     This compliments the existing "name-prefix" (which is used for the UAPI enum names).
>
>     Documentation/netlink/genetlink-legacy.yaml |  6 ++++++
>     tools/net/ynl/pyynl/ynl_gen_c.py            | 13 +++++++++----
>     2 files changed, 15 insertions(+), 4 deletions(-)
>
> Jason, would option B work for you?

So just wg_set_device() -> wg_set_device_doit()? That seems quite fine
to me. And it's probably a better name, too, given that it corresponds
with device_dump. It makes both of those follow the form "wg_{genl
verb}_{nl verb}". I like it.

Jason