[Accel-config] Re: [PATCH] accel-config: Add API to return uacce device path
Thomas, Ramesh <ramesh.thomas at intel.com>
| Newsgroups | dev.linux.lists.accel-config |
|---|---|
| Message-ID | <BYAPR11MB2535E6C3213D33794CB6017DED769@BYAPR11MB2535.namprd11.prod.outlook.com> |
On Mon, Apr 05, 2021 at 05:51:39PM -0700, Dave Jiang
<dave.jiang(a)intel.com> wrote:
> On 4/5/2021 5:40 PM, ramesh.thomas(a)intel.com wrote:
> > From: Ramesh Thomas <ramesh.thomas(a)intel.com>
> >
> > Return path to uacce device path for user wqs. This includes support for
> > legacy mode device names.
> >
> > Signed-off-by: Ramesh Thomas <ramesh.thomas(a)intel.com>
> > ---
> > accfg/lib/libaccel-config.sym | 5 ++++
> > accfg/lib/libaccfg.c | 55 +++++++++++++++++++++++++++++++++++
> > accfg/libaccel_config.h | 1 +
> > 3 files changed, 61 insertions(+)
> >
> > diff --git a/accfg/lib/libaccel-config.sym b/accfg/lib/libaccel-config.sym
> > index 4de2a49..a28ac97 100644
> > --- a/accfg/lib/libaccel-config.sym
> > +++ b/accfg/lib/libaccel-config.sym
> > @@ -141,3 +141,8 @@ global:
> > accfg_remove_mdev;
> > accfg_device_get_mdev_enabled;
> > } LIBACCFG_6;
> > +
> > +LIBACCFG_8 {
> > +global:
> > + accfg_wq_get_uacce_path;
>
> I wonder instead of have a specific call to uacce
> accfg_wq_get_uacce_path, we should just have
> accfg_wq_get_user_dev_path(). And it's capable of providing a path for
> legacy or uacce. And we can get users to just move over to that. The
> user really shouldn't care if it's uacce or something else.
I can give the API a generic name. It currently provides both legacy and
uacce paths.