Re: [PATCH] Bluetooth: hci_bcm4377: Use named initializers for pci_device_id array
Uwe Kleine-König (The Capable Hub) <[email protected]> Sat, 18 Jul 2026 16:08:54 +0200
| Newsgroups | dev.linux.lists.asahi,org.infradead.lists.linux-arm-kernel,org.kernel.vger.linux-bluetooth,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <aluGI7g2BbOsrjoM@monoceros> |
--bwnxy7zgptzm7mmy Content-Type: text/plain; protected-headers=v1; charset=utf-8 Content-Disposition: inline Content-Transfer-Encoding: quoted-printable Subject: Re: [PATCH] Bluetooth: hci_bcm4377: Use named initializers for pci_device_id array MIME-Version: 1.0 On Wed, Jun 10, 2026 at 11:08:49PM +0200, Uwe Kleine-K=C3=B6nig (The Capabl= e Hub) wrote: > Hello, >=20 > On Wed, Jun 10, 2026 at 01:13:44PM -0400, Luiz Augusto von Dentz wrote: > > On Wed, Jun 10, 2026 at 12:59=E2=80=AFPM Uwe Kleine-K=C3=B6nig (The Cap= able Hub) > > <[email protected]> wrote: > > > > > > On Mon, May 04, 2026 at 06:09:40PM +0200, Uwe Kleine-K=C3=B6nig (The = Capable Hub) wrote: > > > > Initializing a struct using list initializers is hard to read, comp= ared > > > > to that using named initializers is more ideomatic. Convert the mac= ro > > > > used to assign values in the driver's pci_device_id array according= ly. > > > > > > > > This change doesn't introduce any changes to the compiled array on = an > > > > x86 and an arm64 build. > > > > > > > > Signed-off-by: Uwe Kleine-K=C3=B6nig (The Capable Hub) <u.kleine-ko= [email protected]> > > > > --- > > > > Hello, > > > > > > > > this is a preparing change for making struct pci_device_id::driver_= data an > > > > anonymous union (similar to > > > > https://lore.kernel.org/all/cover.1776579304.git.u.kleine-koenig@ba= ylibre.com/). > > > > This requires named initializers for .driver_data. But even without= that > > > > this is a nice cleanup making the macro better readable. > > > > > > > > Gcc is happy with simplifying the assignment further using > > > > PCI_VDEVICE(BROADCOM, BCM ## id ## _DEVICE_ID), but this is a bit f= ishy > > > > because PCI_VDEVICE also assigns .class and .class_mask (using list > > > > initializers), so I didn't convert that. > > > > > > In the meantime I learned that doing that would break W=3D1 builds, s= o it > > > was a good choice to not go that path. > > > > > > > Once all pci_device_id use > > > > named initializers, the two zeros can be dropped from PCI_VDEVICE a= nd > > > > this entry simplified accordingly. > > > > > > Is this patch still on someone's radar? Ideally for application in ti= me > > > for 7.2-rc1? > >=20 > > It is no longer in patchwork so if you really want to get in please res= end. >=20 > Instead I unarchived the patch, so it appears in the patch list again. I > hope this is easier for everyone (it is for me). That didn't help, it is archived again. So I'll resend, but I still wonder about the processes involved. Is there a bogous automation that archives patches after a while? Or is someone archiving patches by hand that look old? Both make patchwork as tracker somewhat useless ... Best regards Uwe --bwnxy7zgptzm7mmy Content-Type: application/pgp-signature; name="signature.asc" -----BEGIN PGP SIGNATURE----- iQEzBAABCgAdFiEEP4GsaTp6HlmJrf7Tj4D7WH0S/k4FAmpbiPIACgkQj4D7WH0S /k4c1wf+KcoE7dFmw403md8qqMbo0WQC/qoBEezSjlMwYrzakuDItdFVFoNFBiCw 3EObuzygqxIZE1BYccJoTvjRtkU/V4QVAYqS5pildQ4p7Vt09YDxPiUFxQO3Od6o PyEDcKR7ILURIN4O6peARALntWYwQ4Nzk2NYS03yGSxfNXKc4LIIG6fgrVdcgw+n HeSwcSRmqXFa16BTplVQTAMtsHC4TUC+HieWosDtJeg03LURbBNLamGWO33DrLBs qbaU3zNaHSZvoxXUgEI0W2f2U2J0Gn4RhjRAtB1lOfO1Do1QWz/UWUYjgiiwA0xk JK0AS0bg5Wz9FlvUWkIcrWyp2kTPKA== =sRN4 -----END PGP SIGNATURE----- --bwnxy7zgptzm7mmy--