Re: [PATCH RESEND] Bluetooth: hci_bcm4377: Use named initializers for pci_device_id array

Sven Peter <[email protected]> Sun, 19 Jul 2026 15:15:31 +0200
Newsgroups dev.linux.lists.asahi,org.infradead.lists.linux-arm-kernel,org.kernel.vger.linux-bluetooth,org.kernel.vger.linux-kernel
Message-ID <[email protected]>

On 7/18/26 19:25, Uwe Kleine-König (The Capable Hub) wrote:
> Initializing a struct using list initializers is hard to read, compared
> to that using named initializers is more ideomatic. Convert the macro
> used to assign values in the driver's pci_device_id array accordingly.
>
> This change doesn't introduce any changes to the compiled array on an
> x86 and an arm64 build.
>
> Signed-off-by: Uwe Kleine-König (The Capable Hub) <[email protected]>
> ---

Acked-by: Sven Peter <[email protected]>


Best,


Sven