[PATCH v3 00/16] Introduce and use generic parity16/32/64 helper
Kuan-Wei Chiu <[email protected]>
| Newsgroups | dev.linux.lists.brcm80211,org.freedesktop.lists.dri-devel,org.infradead.lists.linux-mtd,org.kernel.vger.bpf,org.kernel.vger.linux-input,org.kernel.vger.linux-kernel,org.kernel.vger.linux-media,org.kernel.vger.linux-serial,org.kernel.vger.linux-wireless,org.kernel.vger.netdev |
|---|---|
| Message-ID | <[email protected]> |
Several parts of the kernel contain redundant implementations of parity calculations for 16/32/64-bit values. Introduces generic parity16/32/64() helpers in bitops.h, providing a standardized and optimized implementation. Subsequent patches refactor various kernel components to replace open-coded parity calculations with the new helpers, reducing code duplication and improving maintainability. Co-developed-by: Yu-Chun Lin <[email protected]> Signed-off-by: Yu-Chun Lin <[email protected]> Signed-off-by: Kuan-Wei Chiu <[email protected]> --- In v3, I use parityXX() instead of the parity() macro since the parity() macro may generate suboptimal code and requires special hacks to make GCC happy. If anyone still prefers a single parity() macro, please let me know. Additionally, I changed parityXX() << y users to !!parityXX() << y because, unlike C++, C does not guarantee that true casts to int as 1. Changes in v3: - Avoid using __builtin_parity. - Change return type to bool. - Drop parity() macro. - Change parityXX() << y to !!parityXX() << y. Changes in v2: - Provide fallback functions for __builtin_parity() when the compiler decides not to inline it - Use __builtin_parity() when no architecture-specific implementation is available - Optimize for constant folding when val is a compile-time constant - Add a generic parity() macro - Drop the x86 bootflag conversion patch since it has been merged into the tip tree v1: https://lore.kernel.org/lkml/[email protected]/ v2: https://lore.kernel.org/lkml/[email protected]/ Kuan-Wei Chiu (16): bitops: Change parity8() return type to bool bitops: Add parity16(), parity32(), and parity64() helpers media: media/test_drivers: Replace open-coded parity calculation with parity8() media: pci: cx18-av-vbi: Replace open-coded parity calculation with parity8() media: saa7115: Replace open-coded parity calculation with parity8() serial: max3100: Replace open-coded parity calculation with parity8() lib/bch: Replace open-coded parity calculation with parity32() Input: joystick - Replace open-coded parity calculation with parity32() net: ethernet: oa_tc6: Replace open-coded parity calculation with parity32() wifi: brcm80211: Replace open-coded parity calculation with parity32() drm/bridge: dw-hdmi: Replace open-coded parity calculation with parity32() mtd: ssfdc: Replace open-coded parity calculation with parity32() fsi: i2cr: Replace open-coded parity calculation with parity32() fsi: i2cr: Replace open-coded parity calculation with parity64() Input: joystick - Replace open-coded parity calculation with parity64() nfp: bpf: Replace open-coded parity calculation with parity64() drivers/fsi/fsi-master-i2cr.c | 18 ++----- .../drm/bridge/synopsys/dw-hdmi-ahb-audio.c | 8 +-- drivers/input/joystick/grip_mp.c | 17 +----- drivers/input/joystick/sidewinder.c | 24 ++------- drivers/media/i2c/saa7115.c | 12 +---- drivers/media/pci/cx18/cx18-av-vbi.c | 12 +---- .../media/test-drivers/vivid/vivid-vbi-gen.c | 8 +-- drivers/mtd/ssfdc.c | 20 ++----- drivers/net/ethernet/netronome/nfp/nfp_asm.c | 7 +-- drivers/net/ethernet/oa_tc6.c | 19 ++----- .../broadcom/brcm80211/brcmsmac/dma.c | 16 +----- drivers/tty/serial/max3100.c | 3 +- include/linux/bitops.h | 52 +++++++++++++++++-- lib/bch.c | 14 +---- 14 files changed, 77 insertions(+), 153 deletions(-) -- 2.34.1