Re: [PATCH v4 03/13] media: pci: cx18-av-vbi: Replace open-coded parity calculation with parity_odd()
Johannes Berg <[email protected]>
| Newsgroups | dev.linux.lists.brcm80211,org.freedesktop.lists.dri-devel,org.infradead.lists.linux-i3c,org.infradead.lists.linux-mtd,org.kernel.vger.bpf,org.kernel.vger.linux-hwmon,org.kernel.vger.linux-input,org.kernel.vger.linux-kernel,org.kernel.vger.linux-media,org.kernel.vger.linux-serial,org.kernel.vger.linux-wireless,org.kernel.vger.netdev |
|---|---|
| Message-ID | <[email protected]> |
On Wed, 2025-04-09 at 20:43 +0200, Arend van Spriel wrote: > > This is orthogonal to the change to parity_odd() though. More specific > to the new parity_odd() you can now do following as parity_odd() > argument is u64: > > err = !parity_odd(*(u16 *)p); > Can it though? Need to be careful with alignment with that, I'd think. johannes