Re: [PATCH net-next v3 2/5] ipv6: mld: rename mldv2_mrc() and add mldv2_qqi()
Ido Schimmel <[email protected]> Tue, 7 Apr 2026 16:44:29 +0300
| Newsgroups | dev.linux.lists.bridge,org.kernel.vger.linux-kernel,org.kernel.vger.linux-kselftest,org.kernel.vger.netdev |
|---|---|
| Message-ID | <20260407134429.GB849209@shredder> |
On Fri, Apr 03, 2026 at 03:00:47PM +0000, Ujjal Roy wrote: > Rename mldv2_mrc() to mldv2_mrd() as it is used to calculate > the Maximum Response Delay from the Maximum Response Code. > > Introduce a new API mldv2_qqi() to define the existing > calculation logic of QQI from QQIC. This also organizes > the existing mld_update_qi() API. > > Signed-off-by: Ujjal Roy <[email protected]> > --- > include/net/mld.h | 70 +++++++++++++++++++++++++++++++++------ > net/bridge/br_multicast.c | 2 +- > net/ipv6/mcast.c | 19 ++--------- > 3 files changed, 64 insertions(+), 27 deletions(-) Again, code looks fine, but same comments from the previous patch apply here