Re: [PATCH net-next v5 2/5] ipv6: mld: rename mldv2_mrc() and add mldv2_qqi()

Nikolay Aleksandrov <[email protected]> Sat, 2 May 2026 09:03:31 +0300
Newsgroups dev.linux.lists.bridge,org.kernel.vger.linux-kernel,org.kernel.vger.linux-kselftest,org.kernel.vger.netdev
Message-ID <[email protected]>
On 01/05/2026 20:31, Ujjal Roy wrote:
> Rename mldv2_mrc() to mldv2_mrd() as it is used to calculate
> the Maximum Response Delay from the Maximum Response Code.
> 
> Introduce a new API mldv2_qqi() to define the existing
> calculation logic of QQI from QQIC. This also organizes
> the existing mld_update_qi() API.
> 
> Reviewed-by: Ido Schimmel <[email protected]>
> Signed-off-by: Ujjal Roy <[email protected]>
> ---
>   include/net/mld.h         | 66 +++++++++++++++++++++++++++++++++------
>   net/bridge/br_multicast.c |  2 +-
>   net/ipv6/mcast.c          | 19 ++---------
>   3 files changed, 61 insertions(+), 26 deletions(-)
> 

Reviewed-by: Nikolay Aleksandrov <[email protected]>