Re: [RFC PATCH v1 0/6] proc: Add allowlist for procfs files
Andrew Morton <[email protected]> Wed, 25 Jan 2023 15:36:28 -0800
| Newsgroups | dev.linux.lists.containers,org.kernel.vger.linux-fsdevel,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
On Wed, 25 Jan 2023 16:28:47 +0100 Alexey Gladkov <[email protected]> wrote: > The patch expands subset= option. If the proc is mounted with the > subset=allowlist option, the /proc/allowlist file will appear. This file > contains the filenames and directories that are allowed for this > mountpoint. By default, /proc/allowlist contains only its own name. > Changing the allowlist is possible as long as it is present in the > allowlist itself. > > This allowlist is applied in lookup/readdir so files that will create > modules after mounting will not be visible. > > Compared to the previous patches [1][2], I switched to a special virtual > file from listing filenames in the mount options. > Changlog doesn't explain why you think Linux needs this feature. The [2/6] changelog hints that containers might be involved. IOW, please fully describe the requirement and use-case(s). Also, please describe why /proc/allowlist is made available via a mount option, rather than being permanently present. And why add to subset=, instead of a separate mount option. Does /proc/allowlist work in subdirectories? Like, permit presence of /proc/sys/vm/compact_memory? I think the whole thing is misnamed, really. "allowlist" implies access permissions. Some of the test here uses "visibility" and other places use "presence", which are better. "presentlist" and /proc/presentlist might be better. But why not simply /proc/contents? Please run these patches through checkpatch and consider the result.