Re: [RFC PATCH 04/17] Docs/mm/damon/design: document pgidle_unset probe filter type
[email protected] Sat, 25 Jul 2026 21:05:25 +0000
| Newsgroups | dev.linux.lists.damon |
|---|---|
| Message-ID | <[email protected]> |
Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider: - [Low] Typos and grammatically awkward phrasing in the newly added documentation. -- --- Patch [4]: [RFC PATCH 04/17] Docs/mm/damon/design: document pgidle_unset probe filter type --- commit 616f638e60cd5170d7a26046797874f2e31071a4 Author: SJ Park <[email protected]> Docs/mm/damon/design: document pgidle_unset probe filter type This commit updates the DAMON design document to include the newly added pgidle_unset probe filter type. It also formats the supported filter types into a list for improved readability. > diff --git a/Documentation/mm/damon/design.rst b/Documentation/mm/damon/design.rst > index aed6cb1cf4831..d9f64e9ae2879 100644 > --- a/Documentation/mm/damon/design.rst > +++ b/Documentation/mm/damon/design.rst > @@ -293,8 +293,14 @@ registration is made by specifying a probe per attribute. Each of the probe > specifies a rule to determine if a given memory region has the related > attribute. The rule is constructed with multiple filters. The filters work > same to :ref:`DAMOS filters <damon_design_damos_filters>` except the supported > -filter types. Currently only ``anon`` and ``memcg`` filter types are supported > -for data attributes monitoring. > +filter types. Currently below fitler types are supported. [Severity: Low] This isn't a bug, but there is a typo here ("fitler" instead of "filter"). > + > +- ``anon``: Same to that for DAMOS filters. > +- ``memcg``: Same to that for DAMOS filters. > +- ``pgidle_unset``: Matches if the page for the memory is marked as not > + access-idle. > + Matches if the memory is not backed by pages that DAMON can idnetify [Severity: Low] This isn't a bug, but there is a typo here ("idnetify" instead of "identify"). Could this phrasing also be slightly adjusted for better flow? Something like "pages for which DAMON can identify idleness" might read more naturally. > + idleness. > > If such probes are registered, DAMON executes the probes for each region's > sampling memory when it does the access :ref:`sampling -- Sashiko AI review ยท https://sashiko.dev/#/patchset/[email protected]?part=4