Re: [PATCH v2] mm/damon/ops-common: factor out damon_putback_folio_list()
SJ Park <[email protected]>
| Newsgroups | dev.linux.lists.damon,org.kernel.vger.linux-kernel,org.kvack.linux-mm |
|---|---|
| Message-ID | <[email protected]> |
On Tue, 18 Aug 2026 10:06:50 +0800 [email protected] wrote: > From: Li Youhong <[email protected]> > > The putback loop is duplicated in damon_migrate_folio_list() and on the > invalid-nid path of damon_migrate_pages(). Factor it into a small helper > for readability. No functional change. Thank you for this nice cleanup. > > Signed-off-by: Li Youhong <[email protected]> Reviewed-by: SJ Park <[email protected]> This patch is applied to damon/next [1] tree. If this patch is not added to mm.git in short term, I will ask mm.git maintainer (Andrew Morton) to pick this. So, no action from your side is needed for now. Note that we are in the middle of the merge window. Andrew might not pick this until the end of the merge window. I will make the action only after the merge window is closed. If it seems I also forgot doing that or you cannot wait for my action, please feel free to directly ask that to Andrew. [1] https://origin.kernel.org/doc/html/latest/mm/damon/maintainer-profile.html#scm-trees Thanks, SJ [...]