Re: [PATCH v5 1/5] crypto: skcipher - add per-request data_unit_size

Herbert Xu <[email protected]> Mon, 13 Jul 2026 12:19:54 +1000
Newsgroups dev.linux.lists.dm-devel,org.kernel.vger.linux-block,org.kernel.vger.linux-crypto,org.kernel.vger.linux-kernel
Message-ID <[email protected]>
On Tue, Jun 30, 2026 at 08:34:27AM +0000, Leonid Ravich wrote:
>
> @@ -39,6 +46,7 @@ struct scatterlist;
>   */
>  struct skcipher_request {
>  	unsigned int cryptlen;
> +	unsigned int data_unit_size;

Please rename to unit_size to align with the proposed acomp patches.

Thanks,
-- 
Email: Herbert Xu <[email protected]>
Home Page: http://gondor.apana.org.au/~herbert/
PGP Key: http://gondor.apana.org.au/~herbert/pubkey.txt