Re: [PATCH 1/1] block: rename bi_bvec_done

Pavel Begunkov <[email protected]> Thu, 6 Aug 2026 13:21:38 +0100
Newsgroups dev.linux.lists.dm-devel,dev.linux.lists.nvdimm,org.infradead.lists.linux-nvme,org.kernel.vger.ceph-devel,org.kernel.vger.io-uring,org.kernel.vger.linux-block,org.kernel.vger.linux-btrfs,org.kernel.vger.linux-doc,org.kernel.vger.linux-fsdevel
Message-ID <[email protected]>
On 8/6/26 13:19, Pavel Begunkov wrote:
> struct bvec_iter::bi_bvec_done is used an offset in the current bvec,
> let's rename it accordingly for better clarity. I also plan to use it
> for non-bvec based iteration in the future like dma-buf, so drop the
> "bvec" part.

I have this patch for the dma-buf patch set, but it's a very noisy
one, and I've got an impression that it'd be a good thing to do
regardless. Hence sending separately hoping it'd get into 7.3

-- 
Pavel Begunkov