Re: [RFC PATCH 0/4] device_schedule_reprobe(): core helper and conversions
Luiz Augusto von Dentz <[email protected]>
| Newsgroups | dev.linux.lists.driver-core,org.kernel.vger.linux-bluetooth,org.kernel.vger.linux-kernel,org.kernel.vger.linux-wireless,org.kernel.vger.netdev |
|---|---|
| Message-ID | <CABBYNZLHnKnorEbp=LuxcvCUBOpoKHZbV=R9DYzjJyOiFUU06A@mail.gmail.com> |
Hi Hans, On Tue, Aug 11, 2026 at 4:51 AM Hans de Goede <[email protected]> wrote: > > Hi, > > On 11-Aug-26 10:07, Greg Kroah-Hartman wrote: > > On Tue, Aug 11, 2026 at 09:32:45AM +0200, Hans de Goede wrote: > >> Hi Greg, > >> > >> On 11-Aug-26 04:33, Greg Kroah-Hartman wrote: > >>> On Tue, Aug 11, 2026 at 01:47:17AM +0100, Daniel Golle wrote: > >>>> Three in-tree drivers (iwlwifi, hci_h5, btintel_pcie) schedule a > >>>> deferred re-probe of their own device from a work item in module > >>>> text. > >>> > >>> That's a mess, why? Why not fix that up to not do that? Thousands of > >>> other kernel drivers do not do that, what makes these so special? > >> > >> I can only speak for the hci_h5 driver where I added the reprobe code-path. > >> > >> The problem is some of the Bluetooth HCI devices using hci_h5 loose all > >> state during system-suspend. This means that the HCI and the Bluetooth core > >> end up being out of sync. > >> > >> So we basically need to tear down and re-build everything including > >> e.g. the firmware upload which happens at probe(). Doing a full reprobe > >> is by far the easiest way to do this. > >> > >> I suspect the other 4 users + the pending driver which triggered > >> this are similar. > > > > Full reprobe feels different than the THIS_MODULE stuff, which is what I > > objected to here. > > Right, the helper from 1/4 to safely do reprobe from a worker actually > removes the need for THIS_MODULE stuff :) > > The THIS_MODULE stuff in the open-coded implementations is there to > avoid someone doing a rmmod while the reprobe is running. The new > helper replaces this with some checks in the workqueue function > checking the driver has not been rmmod-ed in the mean time. > > >> Sure we can do the whole tear-down + setup from some worker > >> scheduled at resume, while keep the driver attached but if we need > >> to duplicate that over 4 drivers + the pending driver which triggers > >> this then IMHO those 5 users are a pattern which deserves having > >> some helper to do this through the existing probe() + remove(), > >> rather then requiring those 5 drivers to open code this themselves. > >> > >> Note that we already have device_reprobe(), which has 15 existing > >> users. This series just adds a helper to do a device_reprobe() from > >> a worker in a safe way. > > > > That feels a bit better, as long as this code really is "safe" :) > > > > So, how can this be tested and fixed up so it isn't a RFC anymore? > > To me it looks like the main things are: > > 1. Agree that a helper to safely do a device_reprobe() from a worker > is helpful (I think this is done now?) > > 2. Get patch 1/4 reviewed. I can do an initial review but I'm not very > familiar with the driver/device core internals. > > 3. Test this. I can test this on a hci_h5 BT HCI that will hit this > code path. > > I'll try to get 2. and 3. done soon-ish. The 2 Intel drivers are related; they are part of a combo Wi-Fi + BT solution. This is why they attempt to reprobe each other to recover if the entire system (not just wifi or bt) has run into a fault and needs to be recovered as a whole. As for introducing device_schedule_reprobe that seem to be a great initiative, thanks for leading it. -- Luiz Augusto von Dentz