Re: [PATCH v2 3/4] folio_batch: Rename pagevec.h to folio_batch.h
Zi Yan <[email protected]>
| Newsgroups | dev.linux.lists.gfs2,dev.linux.lists.netfs,dev.linux.lists.nvdimm,dev.linux.lists.ocfs2-devel,net.sourceforge.lists.linux-f2fs-devel,org.freedesktop.lists.dri-devel,org.freedesktop.lists.intel-gfx,org.kernel.vger.ceph-devel,org.kernel.vger.cgroups,org.kernel.vger.linux-btrfs,org.kernel.vger.linux-cifs,org.kernel.vger.linux-ext4,org.kernel.vger.linux-fsdevel,org.kernel.vger.linux-kernel,org.kernel.vger.linux-nfs,org.kernel.vger.linux-nilfs,org.kernel.vger.linux-xfs,org.kvack.linux-mm |
|---|---|
| Message-ID | <[email protected]> |
On 25 Feb 2026, at 18:44, Tal Zussman wrote:
> struct pagevec was removed in commit 1e0877d58b1e ("mm: remove struct
> pagevec"). Rename include/linux/pagevec.h to reflect reality and update
> includes tree-wide. Add the new filename to MAINTAINERS explicitly, as
> it no longer matches the "include/linux/page[-_]*" pattern in MEMORY
> MANAGEMENT - CORE.
>
> Signed-off-by: Tal Zussman <[email protected]>
> ---
> MAINTAINERS | 1 +
> drivers/gpu/drm/drm_gem.c | 2 +-
> drivers/gpu/drm/i915/gem/i915_gem_shmem.c | 2 +-
> drivers/gpu/drm/i915/gt/intel_gtt.h | 2 +-
> drivers/gpu/drm/i915/i915_gpu_error.c | 2 +-
> fs/btrfs/compression.c | 2 +-
> fs/btrfs/extent_io.c | 2 +-
> fs/btrfs/tests/extent-io-tests.c | 2 +-
> fs/buffer.c | 2 +-
> fs/ceph/addr.c | 2 +-
> fs/ext4/inode.c | 2 +-
> fs/f2fs/checkpoint.c | 2 +-
> fs/f2fs/compress.c | 2 +-
> fs/f2fs/data.c | 2 +-
> fs/f2fs/node.c | 2 +-
> fs/gfs2/aops.c | 2 +-
> fs/hugetlbfs/inode.c | 2 +-
> fs/nilfs2/btree.c | 2 +-
> fs/nilfs2/page.c | 2 +-
> fs/nilfs2/segment.c | 2 +-
> fs/ramfs/file-nommu.c | 2 +-
> include/linux/{pagevec.h => folio_batch.h} | 8 ++++----
> include/linux/folio_queue.h | 2 +-
> include/linux/iomap.h | 2 +-
> include/linux/sunrpc/svc.h | 2 +-
> include/linux/writeback.h | 2 +-
> mm/filemap.c | 2 +-
> mm/gup.c | 2 +-
> mm/memcontrol.c | 2 +-
> mm/mlock.c | 2 +-
> mm/page-writeback.c | 2 +-
> mm/page_alloc.c | 2 +-
> mm/shmem.c | 2 +-
> mm/swap.c | 2 +-
> mm/swap_state.c | 2 +-
> mm/truncate.c | 2 +-
> mm/vmscan.c | 2 +-
> 37 files changed, 40 insertions(+), 39 deletions(-)
>
Acked-by: Zi Yan <[email protected]>
Best Regards,
Yan, Zi