[PATCH 0/7] arm64: dts: freescale: rename vdevbuffer to vdev0buffer
"Peng Fan (OSS)" <[email protected]> Wed, 29 Jul 2026 09:25:35 +0800
| Newsgroups | dev.linux.lists.imx,org.infradead.lists.linux-arm-kernel,org.kernel.vger.linux-devicetree,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
The imx_rproc driver checks for the name "vdev0buffer" to skip mapping the vdev buffer region, as it is handled by rproc_add_virtio_dev. With the node named "vdevbuffer", the check fails and the region gets unnecessarily mapped. Rename it to "vdev0buffer" across multiple i.MX board dts files to match what the driver expects. In theory, dts should not change because of driver expecting, but the dts changes were landed upstream at late stage, so correct the dts in this patchset. Not critial fixes. No rush for 7.2 Signed-off-by: Peng Fan <[email protected]> --- Peng Fan (7): arm64: dts: imx8dxl-evk: rename vdevbuffer to vdev0buffer arm64: dts: imx8qm-mek: rename vdevbuffer to vdev0buffer arm64: dts: imx8qxp-mek: rename vdevbuffer to vdev0buffer arm64: dts: imx8ulp-evk: rename vdevbuffer to vdev0buffer arm64: dts: imx93-11x11-frdm: rename vdevbuffer to vdev0buffer arm64: dts: imx93-14x14-evk: rename vdevbuffer to vdev0buffer arm64: dts: imx93-9x9-qsb: rename vdevbuffer to vdev0buffer arch/arm64/boot/dts/freescale/imx8dxl-evk.dts | 4 ++-- arch/arm64/boot/dts/freescale/imx8qm-mek.dts | 6 +++--- arch/arm64/boot/dts/freescale/imx8qxp-mek.dts | 4 ++-- arch/arm64/boot/dts/freescale/imx8ulp-evk.dts | 4 ++-- arch/arm64/boot/dts/freescale/imx93-11x11-frdm.dts | 4 ++-- arch/arm64/boot/dts/freescale/imx93-14x14-evk.dts | 4 ++-- arch/arm64/boot/dts/freescale/imx93-9x9-qsb.dts | 4 ++-- 7 files changed, 15 insertions(+), 15 deletions(-) --- base-commit: 0d33d21e47d9dc66f91e44da3fc9220c74d93df7 change-id: 20260728-rproc-dts-3f331df7ceaa Best regards, -- Peng Fan <[email protected]>