Re: [PATCH 09/15] handshake: Add pmksa setter & stealer
James Prestwood <[email protected]>
| Newsgroups | dev.linux.lists.iwd |
|---|---|
| Message-ID | <[email protected]> |
Hi Denis, On 11/25/24 6:56 AM, Denis Kenzior wrote: > Hi James, > > On 11/22/24 9:15 AM, James Prestwood wrote: >> From: Denis Kenzior <[email protected]> >> >> The majority of this patch was authored by Denis Kenzior, but >> I have appended setting the PMK inside handshake_state_set_pmksa >> as well as checking if the pmkid exists in >> handshake_state_steal_pmkid. >> >> Authored-by: Denis Kenzior <[email protected]> >> Authored-by: James Prestwood <[email protected]> >> --- >> Makefile.am | 4 +++ >> src/handshake.c | 77 +++++++++++++++++++++++++++++++++++++++++++++++++ >> src/handshake.h | 11 ++++++- >> 3 files changed, 91 insertions(+), 1 deletion(-) >> > > <snip> > >> @@ -141,7 +142,12 @@ struct handshake_state { >> bool supplicant_ocvc : 1; >> bool ext_key_id_capable : 1; >> bool force_default_ecc_group : 1; >> - uint8_t ssid[SSID_MAX_SIZE]; >> + bool have_pmksa : 1; >> + union { >> + struct pmksa *pmksa; >> + uint64_t expiration; >> + }; >> + uint8_t ssid[32]; > > I changed this back to using SSID_MAX_SIZE instead of the magic number. > >> size_t ssid_len; >> char *passphrase; >> char *password_identifier; > > All 15 patches applied, thanks. Thanks! Bryce, I know you were interested in this. It would be good to see if this allows IWD to pass certification with the wifi alliance. Let us know if you run into any more problems on that front. Thanks, James