Re: [PATCH v2] drm/panel: novatek-nt37801: Use mipi_dsi_*_multi() functions

Doug Anderson <[email protected]> Mon, 13 Jul 2026 13:11:08 -0700
Newsgroups dev.linux.lists.linux-kernel-mentees,org.freedesktop.lists.dri-devel,org.kernel.vger.linux-kernel
Message-ID <CAD=FV=VKA_SKpyew8o64_Fn6qG_mS5snXm1XAazG+3+mn_YJcQ@mail.gmail.com>
Hi,

On Mon, Jul 6, 2026 at 7:31=E2=80=AFPM Doug Anderson <[email protected]=
> wrote:
>
> Hi,
>
> On Mon, Jul 6, 2026 at 3:44=E2=80=AFPM Nicol=C3=A1s Antinori
> <[email protected]> wrote:
> >
> > Replace mipi_dsi_* functions with their non-deprecated mipi_dsi_*_multi
> > counterparts. This change reduces error-checking boilerplate and improv=
es
> > readability.
> >
> > Signed-off-by: Nicol=C3=A1s Antinori <[email protected]>
> > ---
> > Changelog:
> > v2:
> > Implement feedback from the previous thread to simplify code in the
> > novatek_nt37801_prepare() function. This converts novatek_nt37801_on() =
to
> > return void and passes the mipi_dsi_multi_context struct directly as an
> > argument.
> >
> > v1:
> > https://lore.kernel.org/dri-devel/20260701125624.199786-1-nico.antinori=
[email protected]/T/#u
> >
> >  drivers/gpu/drm/panel/panel-novatek-nt37801.c | 110 ++++++++----------
> >  1 file changed, 48 insertions(+), 62 deletions(-)
>
> Yah, looks great. Thanks!
>
> Reviewed-by: Douglas Anderson <[email protected]>
>
> ...barring anything else coming  up, I'll plan to apply in ~1 week.

Pushed to drm-misc-next:

[1/1] drm/panel: novatek-nt37801: Use mipi_dsi_*_multi() functions
      commit: 5958ff1a715dd885210ce7208f1aa1fa930e8671