Re: [PATCH v2] mm/khugepaged: replace mutex_lock/mutex_unlock usage with guard macro

"Zi Yan" <[email protected]> Tue, 28 Jul 2026 21:35:47 -0400
Newsgroups dev.linux.lists.linux-kernel-mentees,org.kernel.vger.linux-kernel,org.kvack.linux-mm
Message-ID <[email protected]>
On Tue Jul 28, 2026 at 4:46 PM EDT, Jakov Novak wrote:
> Currently, khugepaged locks the khugepaged_mutex in two functions:
> start_stop_khugepaged and khugepaged_min_free_kbytes_update. Remove
> mutex_lock/mutex_unlock usage in these functions and replace it with the
> guard macro. This makes the code more readable (removing a goto statement=
)
> and makes it harder to introduce bugs in the future.
> No functional changes introduced.
>
> Signed-off-by: Jakov Novak <[email protected]>
> Reviewed-by: Dev Jain <[email protected]>
> Reviewed-by: Lorenzo Stoakes (ARM) <[email protected]>
> ---
> v2:
>   - Added #include <linux/cleanup.h> to the includes at the top of the fi=
le
>   - Moved err declaration to the scope where it's used in
>     start_stop_khugepaged
>   - Made default case return 0 instead of err in start_stop_khugepaged
>
>  mm/khugepaged.c | 15 ++++++---------
>  1 file changed, 6 insertions(+), 9 deletions(-)
>
> diff --git a/mm/khugepaged.c b/mm/khugepaged.c
> index 617bca76db49..7890bd3e2a9d 100644
> --- a/mm/khugepaged.c
> +++ b/mm/khugepaged.c
> @@ -23,6 +23,7 @@
>  #include <linux/ksm.h>
>  #include <linux/pgalloc.h>
>  #include <linux/backing-dev.h>
> +#include <linux/cleanup.h>
> =20
>  #include <asm/tlb.h>
>  #include "internal.h"
> @@ -3111,18 +3112,17 @@ void set_recommended_min_free_kbytes(void)
> =20
>  int start_stop_khugepaged(void)
>  {
> -	int err =3D 0;
> -
> -	mutex_lock(&khugepaged_mutex);
> +	guard(mutex)(&khugepaged_mutex);
>  	if (hugepage_enabled()) {
>  		if (!khugepaged_thread)
>  			khugepaged_thread =3D kthread_run(khugepaged, NULL,
>  							"khugepaged");
>  		if (IS_ERR(khugepaged_thread)) {
> +			int err;

A new line here?

>  			pr_err("khugepaged: kthread_run(khugepaged) failed\n");
>  			err =3D PTR_ERR(khugepaged_thread);
>  			khugepaged_thread =3D NULL;
> -			goto fail;
> +			return err;
>  		}
> =20
>  		if (!list_empty(&khugepaged_scan.mm_head))

Otherwise, LGTM.

Reviewed-by: Zi Yan <[email protected]>



--=20
Best Regards,
Yan, Zi