Re: [PATCH 2/2] mm/page_alloc: rename FPI_TRYLOCK -> FPI_NOLOCK
Harry Yoo <[email protected]>
| Newsgroups | dev.linux.lists.linux-rt-devel,org.kernel.vger.linux-kernel,org.kvack.linux-mm |
|---|---|
| Message-ID | <[email protected]> |
On 7/10/26 11:14 PM, Zi Yan wrote: > On Fri Jul 10, 2026 at 8:40 AM EDT, Vlastimil Babka (SUSE) wrote: >> On 7/10/26 12:42, Brendan Jackman wrote: >>> As discussed in the linked patch, the there is some inconsistency between >>> "trylock" and "nolock" nomenclature, let's align it. Since "nolock" is >>> used in the public API it seems to have more mindshare so do that. >>> >>> The linked patch did this for the ALLOC_ flag but forgot about FPI_. >>> >>> Link: https://lore.kernel.org/all/[email protected]/ >>> Signed-off-by: Brendan Jackman <[email protected]> >> >> Naming things is hard. Maybe it should have all been called "nospin". I >> don't know anymore :) >> _nolock() functions and ALLOC_NOLOCK are part of API, FPI_ is internal so >> it's not that urgent. Furthermore: > > I had a similar concern when reading ALLOC_TRYLOCK -> ALLOC_NOLOCK[1], > since the name is _NOLOCK, but the comment says spin_trylock. > > I agree that "nospin" is better and less confusing. But whether we want > to churn it again, TBD. :) > > [1] https://lore.kernel.org/all/[email protected]/ Agreed, "nospin" is a better name! At some point I realized "NOLOCK? well, we're using locks, but without spinning. should be NOSPIN?", then thought it's bit late to change the name without churn :) -- Cheers, Harry / Hyeonggon
OpenPGP_signature.asc
(application/pgp-signature, 228 B)
-----BEGIN PGP SIGNATURE----- iHUEARYKAB0WIQQQ1ub6gR5ogjaKRmOGXBN6rc5S1gUCalUT5wAKCRCGXBN6rc5S 1h/7AQCF5kASlmfGZSwsQDL+wbn4ZkmiaE9YxS5ntJj8j7Ik6wEA/deiUAuWtErF 6frBc+P/wyv/2HHN8j9qaE1Wo6yDZg0= =iyK0 -----END PGP SIGNATURE-----