Re: [PATCH v9 02/61] drm/display: hdmi: Rename drmm_connector_hdmi_init() to *_ini2()
Dmitry Baryshkov <[email protected]> Thu, 30 Jul 2026 17:19:55 +0300
| Newsgroups | dev.linux.lists.linux-sunxi,org.freedesktop.lists.dri-devel,org.infradead.lists.linux-arm-kernel,org.infradead.lists.linux-rockchip,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <e4miagjzyvyxxbhbznze3ht4vvnqx5whe24dl3w5sdgasafdmw@gblajrkqr3mc> |
On Thu, Jul 23, 2026 at 04:34:51AM +0300, Cristian Ciocaltea wrote: > In preparation for changing the signature of drmm_connector_hdmi_init(), > i.e. dropping the vendor, product, supported_formats and max_bpc > arguments, which are being moved into struct drm_connector_hdmi_funcs, > temporarily rename the helper to drmm_connector_hdmi_ini2(). > > This lets the new signature be introduced under the original name while > callers are converted incrementally. The final patch removes *_ini2() > once no callers remain. > > This is a mechanical, same-length rename performed with sed: > > $ git grep -l 'drmm_connector_hdmi_init' -- '*.[ch]' \ > | xargs sed -i 's/drmm_connector_hdmi_init/drmm_connector_hdmi_ini2/g' > > The transitional name matches the original's length so continuation-line > arguments stay aligned to the opening parenthesis, keeping the diff to > the identifier itself and avoiding re-alignment churn here and in the > later conversions. > > No functional change intended. > > Signed-off-by: Cristian Ciocaltea <[email protected]> > --- > drivers/gpu/drm/display/drm_bridge_connector.c | 2 +- > drivers/gpu/drm/drm_connector.c | 6 ++-- > drivers/gpu/drm/sun4i/sun4i_hdmi_enc.c | 2 +- > drivers/gpu/drm/tests/drm_connector_test.c | 42 +++++++++++----------- > drivers/gpu/drm/tests/drm_hdmi_state_helper_test.c | 2 +- > drivers/gpu/drm/vc4/vc4_hdmi.c | 2 +- > include/drm/drm_connector.h | 2 +- > 7 files changed, 29 insertions(+), 29 deletions(-) > Reviewed-by: Dmitry Baryshkov <[email protected]> -- With best wishes Dmitry