Re: [PATCH] tools/memory-model: Fix litmus-tests's file names for case-insensitive filesystem.
Szőke Benjamin <[email protected]>
| Newsgroups | dev.linux.lists.lkmm,org.kernel.vger.linux-arch,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
2024. 11. 12. 22:53 keltezéssel, Paul E. McKenney írta: > On Tue, Nov 12, 2024 at 03:20:00PM -0500, Alan Stern wrote: >> On Tue, Nov 12, 2024 at 10:26:37AM -0800, Paul E. McKenney wrote: >>> We do have a rule for the filenames in that directory that most of >>> them follow (I am looking at *you*, "dep+plain.litmus"!). So we have >>> a few options: >>> >>> 1. Status quo. (How boring!!!) >>> >>> 2. Come up with a better rule mapping the litmus-test file >>> contents to the filename, and rename things to follow that rule. >>> (Holy bikeshedding, Batman!) >>> >>> 3. Keep it simple and keep the current rule, but make the >>> combination of spin_lock() and smp_mb__after_spinlock() >>> have a greater Hamming distance from "lock". Szőke's >>> patch changed only one of the filenames containing "Lock". >>> (Bikeshedding, but narrower scope.) >>> >>> 4. One of the above, but bring the litmus tests not following >>> the rule into compliance. >>> >>> 5. Give up on the idea of the name reflecting the contents of the >>> file, and just number them or something. (More bikeshedding >>> and a different form of confusion.) >>> >>> 6. #5, but accompanied by some tool or script that allows easy >>> searching of the litmus tests by pattern of interaction. >>> (Easy for *me* to say!) >>> >>> 7. Something else entirely. >>> >>> Thoughts? >> >> Thumbs up for 3. > > Very good! Any nominations for the lucky replacement for "Lock"? > > Thanx, Paul Subject: [PATCH] tools/memory-model: Fix litmus-tests's file names. Makes a greater Hamming distance for name of Z6.0+pooncelock* files. https://lore.kernel.org/lkml/[email protected]/