Re: [PATCH v7 2/9] rust: sync: Add basic atomic operation mapping framework
Boqun Feng <[email protected]> Mon, 14 Jul 2025 08:34:09 -0700
| Newsgroups | dev.linux.lists.lkmm,org.kernel.vger.linux-arch,org.kernel.vger.linux-kernel,org.kernel.vger.rust-for-linux |
|---|---|
| Message-ID | <[email protected]> |
On Mon, Jul 14, 2025 at 05:00:56PM +0200, Benno Lossin wrote:
> On Mon Jul 14, 2025 at 3:42 PM CEST, Boqun Feng wrote:
> > On Mon, Jul 14, 2025 at 12:03:11PM +0200, Benno Lossin wrote:
> > [...]
> >> > +declare_and_impl_atomic_methods!(
> >> > + /// Basic atomic operations
> >> > + pub trait AtomicHasBasicOps {
> >>
> >> I think we should drop the `Has` from the names. So this one can just be
> >> `AtomicBasicOps`. Or how about `BasicAtomic`, or `AtomicBase`?
> >>
> >
> > Actually, given your feedback to `ordering::Any` vs `core::any::Any`,
> > I think it makes more sense to keep the current names ;-) These are only
> > trait names to describe what operations do an `AtomicImpl` has, and they
> > should be used only in atomic mod, so naming them a bit longer is not a
> > problem. And by doing so, we free the better names `BasicAtomic` or
> > `AtomicBase` for other future usages.
> >
> > Best I could do is `AtomicBasicOps` or `HasAtomicBasicOps`.
>
> But you are already in the `ops` namespace, so by your argument you
> could just use `ops::BasicAtomic` :)
>
> I'm fine with `AtomicBasicOps`.
>
> >> > +declare_and_impl_atomic_methods!(
> >> > + /// Atomic arithmetic operations
> >> > + pub trait AtomicHasArithmeticOps {
> >>
> >> Forgot to rename this one to `Add`? I think `AtomicAdd` sounds best for
> >
> > No, because at the `AtomicImpl` level, it's easy to know whether a type
> > has all the arithmetic operations or none (also the `Delta` type should
> > be known). But I don't have opinions on renaming it to `AtomicAddOps` or
> > `HasAtomicAddOps`.
>
> Ahh right yeah this makes sense. So let's use `AtomicArithmeticOps` if
> you insist on the `Ops` part.
>
Done with AtomicBasicOps AtomicExchangeOps and AtomicArithmeticOps ;-)
Thank you!
Regards,
Boqun
> ---
> Cheers,
> Benno