Re: [PATCH v4 1/3] module/kallsyms: Rename is_mapping_symbol() to is_ignored_kernel_symbol()

Tiezhu Yang <[email protected]>
Newsgroups dev.linux.lists.loongarch,org.kernel.vger.linux-modules
Message-ID <[email protected]>
On 2026/8/24 下午4:45, Huacai Chen wrote:
> Hi, Tiezhu,
> 
> On Thu, Aug 20, 2026 at 8:50 PM Tiezhu Yang <[email protected]> wrote:
>>
>> The helper function is_mapping_symbol() historically checks for both
>> local labels prefixed with ".L" or "L0" and mapping symbols prefixed
>> with "$".
>>
>> Rename it to is_ignored_kernel_symbol() to better reflect this actual
>> behavior and scope, preventing conceptual confusion.
> I think is_ignored_symbol() is enough, no "kernel" needed.

Hi Huacai,

Using is_ignored_kernel_symbol() was suggested by Petr [1] to maintain
consistency with the existing naming convention in tools/perf.

For me, either is_ignored_kernel_symbol() or is_ignored_symbol() is
fine. I will leave it to Petr to make the final call on this.

[1] 
https://lore.kernel.org/loongarch/[email protected]/

Thanks,
Tiezhu
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.