Re: [PATCH v23 05/13] mfd: psci-mfd: Add PSCI MFD driver for cpuidle-psci-domain cell

[email protected]
Newsgroups dev.linux.lists.mfd,org.kernel.vger.linux-devicetree
Message-ID <[email protected]>
Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Low] MFD Naming Convention Violation: Driver and file names hard-code the implementation detail 'mfd'.
--

--- Patch [5]: [PATCH v23 05/13] mfd: psci-mfd: Add PSCI MFD driver for cpuidle-psci-domain cell ---
commit de3054149d7eea49e51e1d55bb38215b4d3e238f
Author: Shivendra Pratap <[email protected]>

mfd: psci-mfd: Add PSCI MFD driver for cpuidle-psci-domain cell

This commit introduces a PSCI MFD driver that binds to the "arm,psci-1.0"
node and registers PSCI child cells. It migrates cpuidle-psci-domain to
probe as an MFD child rather than binding directly to the parent PSCI node.

> diff --git a/drivers/mfd/psci-mfd.c b/drivers/mfd/psci-mfd.c
> new file mode 100644
> index 0000000000000..7affd6bb09dd8
> --- /dev/null
> +++ b/drivers/mfd/psci-mfd.c
[ ... ]
> +static struct platform_driver psci_mfd_driver = {
> +	.probe = psci_mfd_probe,
> +	.driver = {
> +		.name = "psci-mfd",

[Severity: Low]
This isn't a bug, but does this name violate the MFD subsystem naming
conventions?

The subsystem guidelines recommend avoiding the string "mfd" in driver,
struct, or device names to prevent embedding implementation details into
the driver structure.

Could a more descriptive name be used here that omits the "mfd" string?

> +		.of_match_table = psci_mfd_of_match,
> +	},
> +};

-- 
Sashiko AI review · https://sashiko.dev/#/patchset/20260714-arm-psci-system_reset2-vendor-reboots-v23-0-e7453c548c21@oss.qualcomm.com?part=5
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.