Re: [PATCH v23 02/13] power: reset: reboot-mode: Support up to 3 magic values per mode
Bartosz Golaszewski <[email protected]>
| Newsgroups | dev.linux.lists.mfd,org.infradead.lists.linux-arm-kernel,org.kernel.vger.linux-arm-msm,org.kernel.vger.linux-devicetree,org.kernel.vger.linux-kernel,org.kernel.vger.linux-pm |
|---|---|
| Message-ID | <CAMRc=McKp4WsOY-EQ21n2wbqCp5V0Lr1Cbub5geEhz-LZvVkZw@mail.gmail.com> |
On Tue, 14 Jul 2026 19:16:30 +0200, Shivendra Pratap <[email protected]> said: > ARM PSCI vendor-specific resets, require a 32-bit reset_type and a 64-bit > cookie as arguments. This cannot be implemented via the reboot-mode > framework, which supports a single 32-bit argument as magic value. > > Extend the reboot-mode framework to support up to three 32-bit arguments > as magic, per reboot-mode. > > Signed-off-by: Shivendra Pratap <[email protected]> > --- > drivers/power/reset/nvmem-reboot-mode.c | 10 ++++---- > drivers/power/reset/qcom-pon.c | 8 ++++--- > drivers/power/reset/reboot-mode.c | 41 +++++++++++++++++++++----------- > drivers/power/reset/syscon-reboot-mode.c | 8 ++++--- > include/linux/reboot-mode.h | 4 +++- Could we avoid having to modify multiple files here by just providing a new function: nvmem_reboot_mode_write_full() with the prototype you proposed and making the existing nvmem_reboot_mode_write() a thin wrapper around it? Bart