Re: [PATCH v24 01/12] power: reset: reboot-mode: Support up to 3 magic values per mode
[email protected] Mon, 03 Aug 2026 09:56:13 +0000
| Newsgroups | dev.linux.lists.mfd,org.kernel.vger.linux-devicetree |
|---|---|
| Message-ID | <[email protected]> |
> ARM PSCI vendor-specific resets, require a 32-bit reset_type and a 64-bit > cookie as arguments. This cannot be implemented via the reboot-mode > framework, which supports a single 32-bit argument as magic value. >=20 > Extend the reboot-mode framework to support up to three 32-bit arguments > as magic, per reboot-mode. >=20 > Signed-off-by: Shivendra Pratap <[email protected]> Sashiko has reviewed this patch and found no issues. It looks great! --=20 Sashiko AI review =C2=B7 https://sashiko.dev/#/patchset/20260803-arm-psci-s= [email protected]?part=3D1