Re: [PATCH v8 07/10] rust: configfs: use `LocalModule` for `THIS_MODULE`
Andreas Hindborg <[email protected]> Wed, 15 Jul 2026 08:46:42 +0200
| Newsgroups | dev.linux.lists.nova-gpu,dev.linux.lists.driver-core,org.freedesktop.lists.dri-devel,org.kernel.vger.linux-block,org.kernel.vger.linux-kernel,org.kernel.vger.linux-kselftest,org.kernel.vger.linux-modules,org.kernel.vger.linux-pci,org.kernel.vger.netdev,org.kernel.vger.rust-for-linux |
|---|---|
| Message-ID | <[email protected]> |
Alvin Sun <[email protected]> writes: > Replace the `THIS_MODULE` static reference in the `configfs_attrs!` > macro with `this_module::<LocalModule>()`, and update > rnull to import `LocalModule` instead of `THIS_MODULE`, consistent > with the move of `THIS_MODULE` into the `ModuleMetadata` trait. > > Assisted-by: opencode:glm-5.2 > Reviewed-by: Andreas Hindborg <[email protected]> > Acked-by: Danilo Krummrich <[email protected]> > Signed-off-by: Alvin Sun <[email protected]> Acked-by: Andreas Hindborg <[email protected]> Best regards, Andreas Hindborg