[RFC PATCH v4 19/38] NTB: ntb_transport: Rename ntb_transport.c to ntb_transport_core.c
Koichiro Den <[email protected]>
| Newsgroups | dev.linux.lists.ntb,dev.linux.lists.iommu,org.kernel.vger.dmaengine,org.kernel.vger.linux-devicetree,org.kernel.vger.linux-doc,org.kernel.vger.linux-kernel,org.kernel.vger.linux-kselftest,org.kernel.vger.linux-pci,org.kernel.vger.linux-renesas-soc,org.kernel.vger.netdev |
|---|---|
| Message-ID | <[email protected]> |
Prepare for splitting the transport code into a reusable core library and separate client modules. Rename the current implementation file to ntb_transport_core.c to reflect its role and to keep follow-up diffs reviewable. Signed-off-by: Koichiro Den <[email protected]> --- drivers/ntb/Makefile | 2 ++ drivers/ntb/{ntb_transport.c => ntb_transport_core.c} | 0 2 files changed, 2 insertions(+) rename drivers/ntb/{ntb_transport.c => ntb_transport_core.c} (100%) diff --git a/drivers/ntb/Makefile b/drivers/ntb/Makefile index 3a6fa181ff99..9b66e5fafbc0 100644 --- a/drivers/ntb/Makefile +++ b/drivers/ntb/Makefile @@ -4,3 +4,5 @@ obj-$(CONFIG_NTB_TRANSPORT) += ntb_transport.o ntb-y := core.o ntb-$(CONFIG_NTB_MSI) += msi.o + +ntb_transport-y := ntb_transport_core.o diff --git a/drivers/ntb/ntb_transport.c b/drivers/ntb/ntb_transport_core.c similarity index 100% rename from drivers/ntb/ntb_transport.c rename to drivers/ntb/ntb_transport_core.c -- 2.51.0