Re: [PATCH v4 04/12] PCI: endpoint: pci-epf-vntb: Reject unusable doorbell counts

Frank Li <[email protected]> Thu, 14 May 2026 14:55:57 -0400
Newsgroups dev.linux.lists.ntb,org.kernel.vger.linux-kernel,org.kernel.vger.linux-pci
Message-ID <agYavbv1asHSK1RV@lizhi-Precision-Tower-5810>
On Wed, May 13, 2026 at 11:49:15AM +0900, Koichiro Den wrote:
> pci-epf-vntb reserves slot 0 for link events and keeps slot 1 unused for
> legacy layout compatibility. A db_count smaller than MIN_DB_COUNT leaves
> no usable doorbell slot after those reservations.
>
> Reject such configurations when configuring interrupts.
>
> While at it, move MAX_DB_COUNT next to MIN_DB_COUNT. They are used as a
> pair in the range check, and keeping them together makes the valid doorbell
> range easier to read.
>
> Signed-off-by: Koichiro Den <[email protected]>
> ---

Reviewed-by: Frank Li <[email protected]>

> Changes since v3:
>   - New patch.
>
>  drivers/pci/endpoint/functions/pci-epf-vntb.c | 10 ++++++----
>  1 file changed, 6 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/pci/endpoint/functions/pci-epf-vntb.c b/drivers/pci/endpoint/functions/pci-epf-vntb.c
> index d31e2eee0869..818ae5999976 100644
> --- a/drivers/pci/endpoint/functions/pci-epf-vntb.c
> +++ b/drivers/pci/endpoint/functions/pci-epf-vntb.c
> @@ -67,7 +67,6 @@ static struct workqueue_struct *kpcintb_workqueue;
>  #define NTB_MW_OFFSET			2
>  #define DB_COUNT_MASK			GENMASK(15, 0)
>  #define MSIX_ENABLE			BIT(16)
> -#define MAX_DB_COUNT			32
>  #define MAX_MW				4
>
>  /* Limit per-work execution to avoid monopolizing kworker on doorbell storms. */
> @@ -89,6 +88,9 @@ enum epf_irq_slot {
>  	EPF_IRQ_DB_START,
>  };
>
> +#define MIN_DB_COUNT			(EPF_IRQ_DB_START + 1)
> +#define MAX_DB_COUNT			32
> +
>  /*
>   * +--------------------------------------------------+ Base
>   * |                                                  |
> @@ -512,9 +514,9 @@ static int epf_ntb_configure_interrupt(struct epf_ntb *ntb)
>  		return -EINVAL;
>  	}
>
> -	if (!ntb->db_count || ntb->db_count > MAX_DB_COUNT) {
> -		dev_err(dev, "DB count %d out of range (1 - %d)\n",
> -			ntb->db_count, MAX_DB_COUNT);
> +	if (ntb->db_count < MIN_DB_COUNT || ntb->db_count > MAX_DB_COUNT) {
> +		dev_err(dev, "DB count %d out of range (%d - %d)\n",
> +			ntb->db_count, MIN_DB_COUNT, MAX_DB_COUNT);
>  		return -EINVAL;
>  	}
>
> --
> 2.51.0
>