[PATCH 4/9] ACPI: ghes-nvidia: use a named initializer for acpi_device_id::id
"Pawel Zalewski (The Capable Hub)" <[email protected]> Mon, 27 Jul 2026 13:10:42 +0100
| Newsgroups | dev.linux.lists.nvdimm,org.infradead.lists.linux-arm-kernel,org.kernel.vger.linux-acpi,org.kernel.vger.linux-kernel,org.kernel.vger.linux-pci |
|---|---|
| Message-ID | <[email protected]> |
Use a named initializer for the acpi_device_id::id field for readability. Signed-off-by: Pawel Zalewski (The Capable Hub) <[email protected]> --- drivers/acpi/apei/ghes-nvidia.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/acpi/apei/ghes-nvidia.c b/drivers/acpi/apei/ghes-nvidia.c index 597275d81de8..1d3a6997a019 100644 --- a/drivers/acpi/apei/ghes-nvidia.c +++ b/drivers/acpi/apei/ghes-nvidia.c @@ -130,7 +130,7 @@ static int nvidia_ghes_probe(struct platform_device *pdev) } static const struct acpi_device_id nvidia_ghes_acpi_match[] = { - { "NVDA2012" }, + { .id = "NVDA2012" }, { } }; MODULE_DEVICE_TABLE(acpi, nvidia_ghes_acpi_match); -- 2.43.0