Re: [PATCH] staging: gdm724x: Align descendant argument to the open parenthesis

Dan Carpenter <[email protected]>
Newsgroups dev.linux.lists.outreachy,dev.linux.lists.linux-staging,org.kernel.vger.linux-kernel
Message-ID <[email protected]>
On Thu, Mar 28, 2024 at 04:26:47PM -0600, TaheraFahimi wrote:
> Mute the following checkpatch error:
> 	CHECK: Alignment should match open parenthesis

It's not aligned either before or after.  It should have been:

[tab][tab][tab][tab][tab][space][space][space][space][space][space]TTY_DRIVER_...

> 
> Signed-off-by: Tahera Fahimi <[email protected]>
> ---
>  drivers/staging/gdm724x/gdm_tty.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/staging/gdm724x/gdm_tty.c b/drivers/staging/gdm724x/gdm_tty.c
> index 15c246d3b1a3..bd80cd48fb44 100644
> --- a/drivers/staging/gdm724x/gdm_tty.c
> +++ b/drivers/staging/gdm724x/gdm_tty.c
> @@ -272,8 +272,8 @@ int register_lte_tty_driver(void)
>  	int ret;
>  
>  	for (i = 0; i < TTY_MAX_COUNT; i++) {
> -		tty_driver = tty_alloc_driver(GDM_TTY_MINOR,
> -				TTY_DRIVER_REAL_RAW | TTY_DRIVER_DYNAMIC_DEV);
> +		tty_driver = tty_alloc_driver(GDM_TTY_MINOR, TTY_DRIVER_REAL_RAW |
> +						TTY_DRIVER_DYNAMIC_DEV);

"TTY_DRIVER_REAL_RAW | TTY_DRIVER_DYNAMIC_DEV" goes together.  Don't
split that up over two lines.  Checkpatch is a tool which is supposed to
help readability.  It's not a ruler which must be obeyed.  If checkpatch
tells you to do something which makes the code less readable then just
ignore it.

regards,
dan carpenter
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.