Re: [PATCH] staging: greybus: remove unnecessary parentheses
Alex Elder <[email protected]>
| Newsgroups | dev.linux.lists.outreachy,dev.linux.lists.linux-staging,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
On 1/8/25 6:36 PM, Will Walsh wrote: > Unnecessary parentheses in boolean comparisons make it harder to read. > > Removed the extra parentheses on line 305 for code readability. > > Signed-off-by: Will Walsh <[email protected]> I'm not sure this makes a big difference in readability but I personally avoid extra parentheses unless adding them makes a compiler warning go away. Reviewed-by: Alex Elder <[email protected]> > --- > drivers/staging/greybus/audio_codec.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/staging/greybus/audio_codec.c b/drivers/staging/greybus/audio_codec.c > index 2f05e761fb9a..dfb5322964de 100644 > --- a/drivers/staging/greybus/audio_codec.c > +++ b/drivers/staging/greybus/audio_codec.c > @@ -305,7 +305,7 @@ int gbaudio_module_update(struct gbaudio_codec_info *codec, > dev_dbg(module->dev, "%s:Module update %s sequence\n", w->name, > enable ? "Enable" : "Disable"); > > - if ((w->id != snd_soc_dapm_aif_in) && (w->id != snd_soc_dapm_aif_out)) { > + if (w->id != snd_soc_dapm_aif_in && w->id != snd_soc_dapm_aif_out) { > dev_dbg(codec->dev, "No action required for %s\n", w->name); > return 0; > }