Re: [PATCH 5/5] staging: rtl8723bs: modify variable names to comply with kernel naming convention
Julia Lawall <[email protected]> Fri, 28 Mar 2025 16:13:41 +0100 (CET)
| Newsgroups | dev.linux.lists.outreachy,dev.linux.lists.linux-staging,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
On Fri, 28 Mar 2025, Samuel Abraham wrote: > On Fri, Mar 28, 2025 at 3:55 PM Julia Lawall <[email protected]> wrote: > > > > > > > > On Fri, 28 Mar 2025, Abraham Samuel Adekunle wrote: > > > > > The variable names use the camelCase naming convention which is not consistent > > > with Linux kernel naming convention. > > > > > > Modify the names to use snake_case in adherence to the Linux kernel approved > > > naming convention for consistency with the codebase. > > > > There is another naming issue that checkpatch perhaps doesn't warn about > > which is the encoding of types in variable names. You can see some > > variables with names that start with b for boolean and p for pointer. > > Those letters shouldn't be used in kernel code. > > > > julia > > Hello, and thank you very much for your review > Do I send that as a different standalone patch? > Or should I send a v2 after attaching the patch to the patchset? Perhaps find some different files than the ones affected by your patchset and send a standalone patch. julia