[PATCH 2/5] staging: rtl8723bs: replace kmalloc + memset with kzalloc
Erick Karanja <[email protected]> Mon, 31 Mar 2025 18:37:55 +0300
| Newsgroups | dev.linux.lists.outreachy,dev.linux.lists.linux-staging,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <d68a05a05966167f8e54f2fc779af2f1cfe32e07.1743434232.git.karanja99erick@gmail.com> |
Replace a call to kmalloc followed by memset with a single call to kzalloc, which both allocates memory and zeroes it in one step. This change improves readability and reduces redundant code. Signed-off-by: Erick Karanja <[email protected]> --- drivers/staging/rtl8723bs/os_dep/osdep_service.c | 7 +------ 1 file changed, 1 insertion(+), 6 deletions(-) diff --git a/drivers/staging/rtl8723bs/os_dep/osdep_service.c b/drivers/staging/rtl8723bs/os_dep/osdep_service.c index a00f9f0c85c5..be46132a533a 100644 --- a/drivers/staging/rtl8723bs/os_dep/osdep_service.c +++ b/drivers/staging/rtl8723bs/os_dep/osdep_service.c @@ -24,12 +24,7 @@ void *_rtw_malloc(u32 sz) void *_rtw_zmalloc(u32 sz) { - void *pbuf = _rtw_malloc(sz); - - if (pbuf) - memset(pbuf, 0, sz); - - return pbuf; + return kzalloc(sz, in_interrupt() ? GFP_ATOMIC : GFP_KERNEL); } inline struct sk_buff *_rtw_skb_alloc(u32 sz) -- 2.43.0