Re: [PATCH v6 1/2] staging: rtl8723bs: Add white spaces around binary operators

Samuel Abraham <[email protected]> Tue, 8 Apr 2025 10:22:44 +0100
Newsgroups dev.linux.lists.outreachy,dev.linux.lists.linux-staging,org.kernel.vger.linux-kernel
Message-ID <CADYq+fbh=kG2JABmdF8FjjPiyigMpnJ7WhQh+faqRk6FJe4MBQ@mail.gmail.com>
On Tue, Apr 8, 2025 at 8:20 AM Andy Shevchenko
<[email protected]> wrote:
>
> On Tue, Apr 8, 2025 at 12:54 AM Abraham Samuel Adekunle
> <[email protected]> wrote:
> >
> > The code contains no spaces around binary operators making it
> > hard to read. This also doesn't adhere to Linux kernel coding
> > style.
> >
> > Add white spaces around the binary operators to increase readability
> > and endure adherence to Linux kernel coding styles.
>
> ...
>
> > -                                               psta->BA_starting_seqctrl[pattrib->priority & 0x0f] = (tx_seq+1)&0xfff;
> > +                                               psta->BA_starting_seqctrl[pattrib->priority & 0x0f] = (tx_seq + 1) & 0xfff;
>
> > -                                               psta->BA_starting_seqctrl[pattrib->priority & 0x0f] = (pattrib->seqnum+1)&0xfff;
> > +                                               psta->BA_starting_seqctrl[pattrib->priority & 0x0f] = (pattrib->seqnum + 1) & 0xfff;
>
> You mentioned Linux coding style, which also requires lines not to be
> so long. These lines are. That's why a few versions ago I suggested
> you to change these to be two lines each. I don't know how many times
> to repeat this (it's third one).

Okay, sorry
I will add a third patch for a line break before the patch for %
operations since each patch should handle a single thing.

Thanks.