[PATCH v7 0/2] staging: rtl8723bs: Improve readability and clarity of sequence number wrapping
Abraham Samuel Adekunle <[email protected]> Tue, 8 Apr 2025 13:31:40 +0000
| Newsgroups | dev.linux.lists.outreachy,dev.linux.lists.linux-staging,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
The patchset adds spaces around binary operators, breaks long lines to enhance readability and provides clarity on sequence number wrapping by using a modulo operation % 4096u, in place of the bitwise AND(&) operation & 0xfff. The patches are required to be applied in sequence. Changes in v6: - Modified cover letter BLURB to reference newly added line breaks. * PATCH 1: - Added line breaks to long lines to improve readability. - Changed commit message to include the information about the broken lines added to the patch. - Changed subject line title to also include the newly added line breaks. * PATCH 2: - Changed instances of `& 0xfff` to `% 4096u` which were now in the broken lines after the broken lines have been done in PATCH 1. Changes in v5: - Converted the patch with the subject "Use % 4096 instead of & 0xfff" patch to a patchset. - Added a patch to add spaces around binary operator. Changes in v4: - Corrected patch to use '%' instead of '&'. - To ensure this change does not affect the functional behaviour, I compared the generated object files before and after the change using the `cmp` which compares the two object files byte by byte as shown below: $ make drivers/staging/rtl8723bs/core/rtw_xmit.o $ cmp rtw_xmit_before.o rtw_xmit_after.o No differences were found in the output, confirming that the change does not alter the compiled output. Changes in v3: - Added more description to the commit message. - Removed blank line in the tag block. - Added more patch recipients. Changes in v2: - Changed the commit message t a more descriptive message which makes it clear why the patch does the change. - changed the subject title to include `4096u` to show that an unsigned module is used. Changes in v1: - Added more patch recipients. Abraham Samuel Adekunle (2): staging: rtl8723bs: Add spaces and line breaks to improve readability staging: rtl8723bs: Use % 4096 instead of & 0xfff drivers/staging/rtl8723bs/core/rtw_xmit.c | 8 +++++--- 1 file changed, 5 insertions(+), 3 deletions(-) -- 2.34.1