Re: [PATCH 3/3] KVM: VMX: Rename posted interrupt prefixes from "vmx" to "vt"
Xiaoyao Li <[email protected]>
| Newsgroups | dev.linux.lists.sashiko-reviews,org.kernel.vger.kvm |
|---|---|
| Message-ID | <[email protected]> |
On 8/15/2026 1:02 AM, Sean Christopherson wrote: > On Fri, Aug 14, 2026,[email protected] wrote: >> Thank you for your contribution! Sashiko AI review found 3 potential issue(s) to consider: >> - [Low] The function `vmx_needs_pi_wakeup()` was not renamed to `vt_needs_pi_wakeup()`. >> - [Low] The shared inline API `__vmx_deliver_posted_interrupt()` was not renamed to `__vt_deliver_posted_interrupt()`. >> - [Low] A comment inside `vt_can_use_vtd_pi()` references the old `vmx_pi_start_bypass()` function name. >> -- > I also missed vmx_handle_nmi() and __vmx_handle_ept_violation(). So for TDX VMDoS series, I need to rename __vmx_handle_notify() to vt_handle_notify() and extract handle_bus_lock_vmexit() from vmx.c to main.c as vt_handle_bus_lock_vmexit() or just inline function in common.h?