Re: [PATCH v2 2/3] net: phy: Add helper for fixing RGMII PHY mode based on internal mac delay
Andrew Lunn <[email protected]>
| Newsgroups | dev.linux.lists.sophgo,org.infradead.lists.linux-arm-kernel,org.kernel.vger.linux-devicetree,org.kernel.vger.linux-kernel,org.kernel.vger.netdev |
|---|---|
| Message-ID | <[email protected]> |
On Mon, Oct 20, 2025 at 05:54:58PM +0800, Inochi Amaoto wrote: > The "phy-mode" property of devicetree indicates whether the PCB has > delay now, which means the mac needs to modify the PHY mode based > on whether there is an internal delay in the mac. > > This modification is similar for many ethernet drivers. To simplify > code, define the helper phy_fix_phy_mode_for_mac_delays(speed, mac_txid, > mac_rxid) to fix PHY mode based on whether mac adds internal delay. > > Signed-off-by: Inochi Amaoto <[email protected]> > --- > drivers/net/phy/phy-core.c | 43 ++++++++++++++++++++++++++++++++++++++ > include/linux/phy.h | 3 +++ > 2 files changed, 46 insertions(+) > > diff --git a/drivers/net/phy/phy-core.c b/drivers/net/phy/phy-core.c > index 605ca20ae192..4f258fb409da 100644 > --- a/drivers/net/phy/phy-core.c > +++ b/drivers/net/phy/phy-core.c > @@ -101,6 +101,49 @@ const char *phy_rate_matching_to_str(int rate_matching) > } > EXPORT_SYMBOL_GPL(phy_rate_matching_to_str); > > +/** > + * phy_fix_phy_mode_for_mac_delays - Convenience function for fixing PHY > + * mode based on whether mac adds internal delay > + * > + * @interface: The current interface mode of the port > + * @mac_txid: True if the mac adds internal tx delay > + * @mac_rxid: True if the mac adds internal rx delay > + * > + * Return fixed PHY mode, or PHY_INTERFACE_MODE_NA if the interface can > + * not apply the internal delay > + */ I think a helper like this is a good idea. But there are a couple of things i don't like about this implementation. I don't like returning PHY_INTERFACE_MODE_NA on error. I would prefer -EINVAL. of_get_phy_mode() passed a phy_interface_t *, and returns an errno. The same would be good here. I find: phy_fix_phy_mode_for_mac_delays(interface, true, false) hard to read. You cannot see what these true/false mean. Which is Rx and which is Tx? Rather than true false, how about passing an PHY_INTERFACE_MODE_RGMII_* values? PHY_INTERFACE_MODE_RGMII_ID would indicate the MAC is doing both delays. PHY_INTERFACE_MODE_RGMII_RXID the MAC is implementing the RX delay? I'm open to other ideas here. Andrew