Re: [PATCH v3 0/6] riscv: spacemit: Add PCIe RC controller support for K3
Aurelien Jarno <[email protected]> Fri, 3 Jul 2026 19:15:56 +0200
| Newsgroups | dev.linux.lists.spacemit,org.infradead.lists.linux-riscv,org.kernel.vger.linux-devicetree,org.kernel.vger.linux-kernel,org.kernel.vger.linux-pci |
|---|---|
| Message-ID | <[email protected]> |
On 2026-07-03 09:59, Inochi Amaoto wrote: > The PCIe controller on Spacemit K3 is almost a standard Synopsys > Designware PCIe IP with extra control and external MSI controller > (IMSIC). > > Add binding and driver support for PCIe RC controller support on K3. > > Changed from v2: > - https://lore.kernel.org/linux-pci/[email protected]/ > patch 2: > 1. Use unify PCIe phy get/enable/exit function for both K1 and K3. > patch 3: > 1. New patch for updating device id for both K1/K3 > patch 5: > 1. Reuse binding for spacemit,k1-pcie-host > patch 6: > 1. Multiple cleanup for the logic already generalized in the previous > patches. > 2. Use generic description for the Kconfig entry. > > Changed from v1: > patch 1: > 1. Remove post_init callback. > patch 2: > 1. Fix devm_kmalloc_array arguments order and error check. > patch 3: > 1. Apply Rob's tag. > 2. Change check from oneOf to anyOf. > 3. Fix spelling mistakes in commit message. > patch 4: > 1. Add comment about PHY handle. > 2. Remove interrupt "app". > 3. Fix spelling mistakes in commit message. > patch 5: > 1. Remove all logic related to link up interrupt. > 2. Clean up all unused macros. > 3. Fix devm_kmalloc_array arguments order and error check. > 4. Remove unnecessary start_link logic. > 5. Make all magic number as a macro. > 6. Fix spelling mistakes in code and commit message. > > Inochi Amaoto (6): > PCI: spacemit-k1: Add device data support > PCI: spacemit-k1: Add multiple PHY handles support > PCI: spacemit-k1: Add device id update helper > dt-bindings: PCI: snps,dw-pcie: Add msi-parent for MSI handle check > dt-bindings: PCI: spacemit: Introduce Spacemit K3 PCIe host controller > PCI: spacemit-k1: Add Spacemit K3 PCIe host controller support > > .../devicetree/bindings/pci/snps,dw-pcie.yaml | 7 +- > .../bindings/pci/spacemit,k1-pcie-host.yaml | 46 +++- > drivers/pci/controller/dwc/Kconfig | 4 +- > drivers/pci/controller/dwc/pcie-spacemit-k1.c | 237 ++++++++++++++++-- > 4 files changed, 267 insertions(+), 27 deletions(-) > For patches 1, 2, 3 and 6: Tested-by: Aurelien Jarno <[email protected]> -- Aurelien Jarno GPG: 4096R/1DDD8C9B [email protected] http://aurel32.net