Re: [PATCH 1/6] virtio: Add bool to VirtQueueElement

Jonah Palmer <[email protected]> Fri, 10 May 2024 06:26:43 -0400
Newsgroups dev.linux.lists.virtio-fs,org.nongnu.qemu-devel
Message-ID <[email protected]>

On 5/9/24 8:32 AM, Eugenio Perez Martin wrote:
> On Mon, May 6, 2024 at 5:06 PM Jonah Palmer <[email protected]> wrote:
>>
>> Add the boolean 'filled' member to the VirtQueueElement structure. The
>> use of this boolean will signify if the element has been written to the
>> used / descriptor ring or not. This boolean is used to support the
>> VIRTIO_F_IN_ORDER feature.
>>
>> Tested-by: Lei Yang <[email protected]>
>> Signed-off-by: Jonah Palmer <[email protected]>
>> ---
>>   include/hw/virtio/virtio.h | 1 +
>>   1 file changed, 1 insertion(+)
>>
>> diff --git a/include/hw/virtio/virtio.h b/include/hw/virtio/virtio.h
>> index 7d5ffdc145..9ed9c3763c 100644
>> --- a/include/hw/virtio/virtio.h
>> +++ b/include/hw/virtio/virtio.h
>> @@ -69,6 +69,7 @@ typedef struct VirtQueueElement
>>       unsigned int ndescs;
>>       unsigned int out_num;
>>       unsigned int in_num;
>> +    bool filled;
> 
> in_order_filled? I cannot come with a good name for this. Maybe we can
> add a comment on top of the variable so we know what it is used for?
> 

Will do! I can change the name to be more obvious as well.

>>       hwaddr *in_addr;
>>       hwaddr *out_addr;
>>       struct iovec *in_sg;
>> --
>> 2.39.3
>>
>