Re: [PATCH v9 01/11] sched/docs: Document cpu_preferred_mask and Preferred CPU concept
Shrikanth Hegde <[email protected]> Tue, 4 Aug 2026 20:52:40 +0530
| Newsgroups | dev.linux.lists.virtualization,org.kernel.vger.linux-doc,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
Hi Yury,
On 7/30/26 10:34 AM, Yury Norov wrote:
> On Sat, Jul 25, 2026 at 07:52:24AM +0530, Shrikanth Hegde wrote:
>> I don't think any other file in there are a choice.
>> So, I guess I need to add a new one named sched-preferred-cpu.rst
>
> Maybe sched-paravirt.rst?
Ok. Will add a new one.
======================================================
To Everyone,
I am still waiting for the system to run numbers on next version that i have.
Performance is expected to be same as v9 apart from system to system variations,
but i still want to run it once before sending it.
Changes prepared as of now for next version. If there are any other review comments
meanwhile, please let me know.
PATCH 1:
- Move the documentation bits into Documentation/scheduler/sched-paravirt.rst
(New file instead of adding to sched-arch.rst)
PATCH 5:
- Remove cpu_preferred check in _nohz_idle_balance
This would naturally allow nohz.next_balance to happen
as should_we_balance fails and load balance bails out
on non-preferred CPUs and time gets updated.
PATCH 5:
- Add cpu_preferred check in find_new_ilb to select an preferred
idle CPU for idle load balancing.
This may need to be rebased if andrea's patch lands upstream
before my next version.
https://lore.kernel.org/all/[email protected]/
PATCH 8:
- Add details about thresholds limitations.
- Minor documentation nits.
NEW PREP PATCH:
- Introduce kcpustat_field_total to sum up kcpustat for specified type over
set of cpus. That will likely becomes first patch in next version.
https://lore.kernel.org/all/[email protected]/
PATCH 10:
- Rename compute_preferred_cpus_work to steal_governor_loop
- Mention in the changelog and documentation that default thresholds it won't work in
all cases and user might have to change them based on the system under test.
- Always do the design checks. That will avoid any driver related design
checks into core code. All the core code needs to take care is w.r.t to hotplug
that preferred is set after active and reset before active. Add this specific case
details in changelog why design checks are done always.
- Add changelog/doc on how the it safely handles half-offlined core.
Assumed as concluded and not changing for next version:
- returning void in sched_non_preferred_cpu_push_stop is out of the scope of this series.
- Using possible CPUs for computing steal ratio.
- fs/proc/stat.c and drivers/leds/trigger/ledtrig-activity.c etc not using kcpustat_field_total.