Re: [PATCH v1 0/9] x86/cpuid: Headers cleanup

Ingo Molnar <[email protected]>
Newsgroups dev.linux.lists.x86-cpuid,org.kernel.vger.linux-kernel
Message-ID <[email protected]>
* Ahmed S. Darwish <[email protected]> wrote:

> Hi,
> 
> This is a CPUID headers cleanup series, on top of tip:x86/cpu.  It is a
> precursor for the upcoming v2 of the CPUID parser:
> 
>     [PATCH v1 00/26] x86: Introduce centralized CPUID model
>     https://lore.kernel.org/lkml/[email protected]
> 
> as suggested by Ingo here:
> 
>     https://lore.kernel.org/lkml/[email protected]
> 
> * Summary:
> 
> The current CPUID header structure is:
> 
>     include/asm/
>     ├── cpuid
>     │   ├── api.h
>     │   ├── leaf_0x2_api.h
>     │   └── types.h
>     └── cpuid.h
> 
> Simplify it into:
> 
>     include/asm/
>     ├── api.h
>     └── types.h
> 
> Standardize the CPUID header namespace by enforcing a "cpuid_" prefix for
> all exported symbols.  That is:
> 
>     have_cpuid_p()		➤	cpuid_feature()
>     hypervisor_cpuid_base()	➤	cpuid_hypervisor_base()
>     native_cpuid()		➤	cpuid_native()
>     native_cpuid_REG()		➤	cpuid_native_REG()
> 
> Also rename:
> 
>     cpuid_get_leaf_0x2_regs()	➤	cpuid_leaf_0x2()
> 
> for consistency with the other <asm/cpuid/api.h> accessors that return
> full CPUID register output; i.e., cpuid_leaf() and cpuid_subleaf().
> 
> Finally, rename:
> 
>     for_each_leaf_0x2_entry()   ➤	for_each_cpuid_0x2_desc()
> 
> to include "cpuid" in the iterator name, and since what is being iterated
> upon is CPUID(0x2) cache and TLB "descriptos", not "entries".
> 
> * Testing:
> 
> - Basic one-by-one allyesconfig compilation
> 
> - Comparison of a before/after of below files:
> 
>   - /proc/cpuinfo
>   - /sys/devices/system/cpu/
>   - /sys/kernel/debug/x86/topo/
>   - dmesg --notime | grep 'Last level [id]TLB entries'
> 
> Thanks!
> 
> 8<--
> 
> Ahmed S. Darwish (9):
>   x86/cpuid: Move CPUID(0x2) APIs into <cpuid/api.h>
>   x86/cpuid: Set <asm/cpuid/api.h> as the main CPUID header
>   x86/cpuid: Rename have_cpuid_p() to cpuid_feature()
>   x86/cpuid: Rename hypervisor_cpuid_base() to cpuid_hypervisor_base()
>   x86/cpuid: Rename cpuid_get_leaf_0x2_regs() to cpuid_leaf_0x2()
>   x86/cacheinfo: Rename CPUID(0x2) descriptors iterator parameter
>   x86/cpu: Rename CPUID(0x2) descriptors iterator parameter
>   x86/cpuid: Rename native_cpuid() to cpuid_native()
>   x86/cpuid: Rename native_cpuid_REG() to cpuid_native_REG()

Thank you for doing this. I've reviewed the series and applied these:

    x86/cpuid: Move CPUID(0x2) APIs into <cpuid/api.h>
    x86/cpuid: Set <asm/cpuid/api.h> as the main CPUID header
    x86/cpuid: Rename have_cpuid_p() to cpuid_feature()
    x86/cpuid: Rename cpuid_get_leaf_0x2_regs() to cpuid_leaf_0x2()
    x86/cacheinfo: Rename CPUID(0x2) descriptors iterator parameter
    x86/cpu/intel: Rename CPUID(0x2) descriptors iterator parameter

I had some questions about:

    x86/cpuid: Rename hypervisor_cpuid_base() to cpuid_hypervisor_base()
    x86/cpuid: Rename native_cpuid() to cpuid_native()

and you had better ideas about:

    x86/cpuid: Rename native_cpuid_REG() to cpuid_native_REG()

Thanks,

	Ingo
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.