Re: [PATCH v1 4/9] x86/cpuid: Rename hypervisor_cpuid_base() to cpuid_hypervisor_base()
"Ahmed S. Darwish" <[email protected]>
| Newsgroups | dev.linux.lists.x86-cpuid,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <aCYy9Blvu3jH-LJE@lx-t490> |
On Thu, 15 May 2025, Ingo Molnar wrote: > > So the interaction here looks a bit weird IMO (what is a 'hypervisor > base'?), and I think the 'CPUID base' phrase should be immutable. > > Ie. I think it would be more natural to call this method > cpuid_base_hypervisor(), which would mix reasonably well with: > > kvm_cpuid_base() > xen_cpuid_base() > jailhouse_cpuid_base() > > These lower level methods are prefixed with kvm_/xen_/jailhouse_, as > most of their internal methods are. > > Likewise, for_each_possible_cpuid_base_hypervisor()? > Makes sense; will do.