Re: [PATCH v1 0/9] x86/cpuid: Headers cleanup
"Ahmed S. Darwish" <[email protected]>
| Newsgroups | dev.linux.lists.x86-cpuid,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <aCY3c5l7FFdwvvv9@lx-t490> |
On Thu, 15 May 2025, Ingo Molnar wrote:
>
> Thank you for doing this. I've reviewed the series and applied these:
>
> x86/cpuid: Move CPUID(0x2) APIs into <cpuid/api.h>
> x86/cpuid: Set <asm/cpuid/api.h> as the main CPUID header
> x86/cpuid: Rename have_cpuid_p() to cpuid_feature()
> x86/cpuid: Rename cpuid_get_leaf_0x2_regs() to cpuid_leaf_0x2()
> x86/cacheinfo: Rename CPUID(0x2) descriptors iterator parameter
> x86/cpu/intel: Rename CPUID(0x2) descriptors iterator parameter
>
> I had some questions about:
>
> x86/cpuid: Rename hypervisor_cpuid_base() to cpuid_hypervisor_base()
> x86/cpuid: Rename native_cpuid() to cpuid_native()
>
> and you had better ideas about:
>
> x86/cpuid: Rename native_cpuid_REG() to cpuid_native_REG()
>
Thanks a lot for all the support as usual :)
I'll send a v2 then for the single one left:
x86/cpuid: Rename hypervisor_cpuid_base() to cpuid_hypervisor_base()
and indeed drop:
x86/cpuid: Rename native_cpuid() to cpuid_native()
x86/cpuid: Rename native_cpuid_REG() to cpuid_native_REG()
All the best,
~ Ahmed