Re: [PATCH v6 36/90] x86/cpuid: Parse deterministic cache parameters CPUID leaves

Maciej Wieczor-Retman <[email protected]> Fri, 17 Apr 2026 11:20:27 +0200
Newsgroups dev.linux.lists.x86-cpuid,org.kernel.vger.linux-kernel
Message-ID <[email protected]>
On 2026-03-27 at 03:15:50 +0100, Ahmed S. Darwish wrote:
>Introduce the macro
>
>    define_cpuid_read_function()
>
>to avoid code duplication between the CPUID parser default read function,
>cpuid_read_generic(), and the new CPUID(0x4)/CPUID(0x8000001d) logic.

Maybe it's worth updating the comment above "struct cpuid_read_output" so it
mentions that cpuid_read_generic() is macro generated now? Right now if someone
would grep to find cpuid_read_generic() they couldn't find it.

Or otherwise adding the after-macro function name to a comment around
define_cpuid_read_function() calls could work for other cases too.

-- 
Kind regards
Maciej Wieczór-Retman