[PATCH v7 062/120] x86/acpi/cstate: Use MWAIT helper macros
"Ahmed S. Darwish" <[email protected]> Thu, 28 May 2026 17:38:24 +0200
| Newsgroups | dev.linux.lists.x86-cpuid,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
Use <asm/mwait.h> MWAIT_HINT2CSTATE() instead of open-coding its logic. No functional change. Signed-off-by: Ahmed S. Darwish <[email protected]> --- arch/x86/kernel/acpi/cstate.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/arch/x86/kernel/acpi/cstate.c b/arch/x86/kernel/acpi/cstate.c index dbdacfbf53bd..4e7142d977c8 100644 --- a/arch/x86/kernel/acpi/cstate.c +++ b/arch/x86/kernel/acpi/cstate.c @@ -132,8 +132,7 @@ static long acpi_processor_ffh_cstate_probe_cpu(void *_cx) cpuid(CPUID_LEAF_MWAIT, &eax, &ebx, &ecx, &edx); /* Check whether this particular cx_type (in CST) is supported or not */ - cstate_type = (((cx->address >> MWAIT_SUBSTATE_SIZE) & - MWAIT_CSTATE_MASK) + 1) & MWAIT_CSTATE_MASK; + cstate_type = (MWAIT_HINT2CSTATE(cx->address) + 1) & MWAIT_CSTATE_MASK; edx_part = edx >> (cstate_type * MWAIT_SUBSTATE_SIZE); num_cstate_subtype = edx_part & MWAIT_SUBSTATE_MASK; -- 2.54.0